Technical Requirements for Online Education

General Platform Requirements:

You must have reliable access to a PC or Mac computer, as well as reliable internet access throughout the duration of the course.

Mobile Devices:

Our courses have some issues for mobile devices so while you may find that most functionality is accessible on mobile devices, we cannot support mobile devices at this time.

If you would like to try your mobile device for our courses we find that the Canvas Student app gives the best experience. Please be sure you use the Canvas Student app and not the Canvas Teacher app.

While tablets, phones, and other mobile devices may allow you to access some of the course content, the CAC will not be able to assist you with issues you encounter on mobile devices or with the Canvas mobile app. If you do find functionality that doesn’t work on your mobile device you will need to use a laptop or desktop for that aspect of the course.

Computer Facility Skills:

CAC courses are 100% online. To make the most of what the course offers, we strongly encourage you to have, at the very least, basic computer and Web navigation skills; the ability to copy and paste, while not absolutely required, will be very helpful as well.

Technical support for the online instruction platform is available during the first week through the Help Forum and throughout the rest of the course via email at [email protected]There is no provision for technical support over the phone.

Language:

CAC courses are entirely in English. You will benefit most if you have strong English reading and writing skills.

Computer System:

  • For PC computers: Pentium 4 or better, Windows 7 or better operating system
  • For Macintosh computers: OS X
  • 4 GB of RAM (or more)
  • 1 GB of free disk space (or more)
  • Internet access via direct network connection (high-speed BROADBAND access) is highly recommended. Dial-up access will NOT WORK, and satellite access will be problematic
  • Sound card and speakers or headset
  • Printer (optional)

Browser Requirements:

We recommend that you use the latest version of your internet browser. Minimum versions are noted below:

  • Firefox: 25.0
  • Google Chrome: 30.0

All browsers should have Cookies and Pop-ups enabled (Pop-up blocker must be turned off). 

Note: If you choose to use an unrecommended browser, you may need to install Adobe Flash.

The work of the Center for Action and Contemplation is possible only because of friends and supporters like you!

Learn more about making a donation to the CAC.

FacebookTwitterEmailPrint